Home Forum Joining Contact Links News Articles Gallery Members
Discovery Owners Club
Home Forum Joining Contact Links News Articles Gallery Members
It is currently Sat Oct 19, 2019 8:35 pm

Discovery Owners Club

Have YOUR say on the DOC forum...

  • Advertisement
Noel Dazely Insurance

Discovery 1 (300 tdi) running issues

If you're not a member of the club yet and you've got questions about membership before you join, please post them here.

Moderator: Committee

 

Discovery 1 (300 tdi) running issues

Post by Phil Wood » Tue Jul 25, 2017 11:26 am

Dear all,

Please could one of you fine people offer some suggestions to solve the following problem on my 300TDI Discovery 1:


Some days ago, the Disco started developing the following fault:

Was running fine / Still starts up and ticks over fine / but ...when driving with engine under any kind of load, vehicle starts losing power / spluttering / kangaroo juice symptoms.

I have tried the following without success:

Alternative fuel source
New fuel filter
Cleaned fuel pipes
Cleaned fuel lift pump

Any suggestions would be greatly appreciated.

User avatar
 
Posts: 7018
Joined: Sun May 06, 2007 4:44 pm
Location: Gloucestershire, GB
Membership Number: 1449
Full name: Richard Knapp

Re: Discovery 1 (300 tdi) running issues

Post by Knappster » Wed Aug 02, 2017 9:29 pm

The symptoms sound similar to a sticking EGR. It is simple to remove and blank off.

Rich.
DREAM GREEN TEAM.004

Land Rover 90 with Disco 200Tdi and Series 3 SWB soon to have a 200Tdi!

User avatar
 
Posts: 867
Joined: Mon Sep 24, 2007 9:21 am
Location: Avon, GB
Membership Number: 3461
Full name: Mark Chamberlain

Re: Discovery 1 (300 tdi) running issues

Post by Markc » Thu Aug 03, 2017 6:58 pm

If there's exhaust smoke, it could be the turbo hoses delaminating internally.
Mark

2002 L322 Range Rover.
Never twice the same fault code.

Tug- 1994 300Tdi Commercial. Gone but not forgotten.

User avatar
 
Posts: 2085
Joined: Mon Aug 29, 2005 12:26 pm
Location: Pembrokeshire, GB
Membership Number: 2205
Full name: Andrew Miles

Re: Discovery 1 (300 tdi) running issues

Post by Bluestone Wanderer » Wed Oct 11, 2017 3:12 pm

A sticking EGR will usually be accompanied with excessive smoke.

The symptoms you have mentioned suggest to me that you need a new fuel lift pump.

If you get a replacement make sure it is a quality unit such as delphi.
DREAM GREEN TEAM 006

Green TD5 ES Premium "Esme"
Red D4 SE Tech (Rosie)
Range Rover DSE Saffi"
Disco dogs Holly 026 RIP, Coco 027 RIP, Merlin 084, Alice 094 & Griff 098 & 2 Landrover Mountain Bikes
http://www.speedofsight.co.uk/
http://www.bluebirdspeedrecords.com/


Return to Non-Members' Questions

Who is online

Users browsing this forum: No registered users and 1 guest

  • Advertisement
Adrian Flux Insurance