Home Forum Joining Contact Links News Articles Gallery Members
Discovery Owners Club
Home Forum Joining Contact Links News Articles Gallery Members
It is currently Tue Jul 16, 2019 6:48 pm

Discovery Owners Club

Have YOUR say on the DOC forum...

  • Advertisement
Adrian Flux Insurance

Headlight issue!

If you're not a member of the club yet and you've got questions about membership before you join, please post them here.

Moderator: Committee

 

Headlight issue!

Post by DanD1 » Wed Sep 27, 2017 8:07 am

Hi Guys/Gals

This is really annoying now!

I have hardly any power going to my left side front light. side light works fine but the main beam and high beam wont work.. Ive also tried wiring my led spot to the loom, there isnt enough power to light that up!

Someone please point me in the right direction!

New to D1s if you havent already guessed lol

Also how do I get membership??

Cheers Dan

User avatar
 
Posts: 2084
Joined: Mon Aug 29, 2005 12:26 pm
Location: Pembrokeshire, GB
Membership Number: 2205
Full name: Andrew Miles

Re: Headlight issue!

Post by Bluestone Wanderer » Fri Oct 06, 2017 4:40 pm

Corrosion on the connectors, bad earth, blown bulbs or fuses are the most likely causes.

Start at the bulb connector then work back to fusebox, relays and even headlight switches.

If voltage is just low at the connector there are relays and small loom available that are switched by the headlamp connector and provide full battery voltage to a new headlamp connector.

Someone on this site used to make them but they are available on ebay.

http://www.ebay.co.uk/itm/H4-Headlight- ... Swa~BYV7YK
DREAM GREEN TEAM 006

Green TD5 ES Premium "Esme"
Red D4 SE Tech (Rosie)
Range Rover DSE Saffi"
Disco dogs Holly 026 RIP, Coco 027 RIP, Merlin 084, Alice 094 & Griff 098 & 2 Landrover Mountain Bikes
http://www.speedofsight.co.uk/
http://www.bluebirdspeedrecords.com/

User avatar
 
Posts: 936
Joined: Sun Aug 31, 2003 7:06 pm
Location: North Yorkshire, GB
Membership Number: 1354
Full name: Roy Preston

Re: Headlight issue!

Post by benji89 » Fri Oct 06, 2017 6:51 pm

Hi Dan.
I hope you get it fixed for the winter.
You will be most welcome to join the DOC, and can do so by clicking the "Joining" at the top of this page.
Or contact me at the address below.
Best regards.
Roy.
Membership Secretary.
memsec@discoveryownersclub.org

G478WAC. Foxfire Red V8. Now started restoration
G513DHP. A pre pro V8i 5-door. Will be on display at the 2019 shows
G526WAC. One of the 86 LR demo cars at the launch on the Hoe October 1989
G628BKV. March 1990 3-door Tdi in Davos white
L637LRX. 2.0 Mpi 5-door. A rare model now
L680YVV. A '93 Tdi 3-door in black. My winter wheels 2018/19
KJ04ZXB. Rover 75 Club SE. My daily driver
L270MCF. Honda Crossroad.


Return to Non-Members' Questions

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

  • Advertisement
Noel Dazely Insurance